Cisco

How to redistribute static routes into eigrp using Cisco Packet Tracer

Route redistribution is a great way to share routes between routers running different routing protocols or routers running the same dynamic routing protocol but in different autonomous systems. In this simple demonstration, using the Cisco Packet Tracer, I will share with us on how to redistribute static routes into an eigrp autonomous system.

Statement of the problem

Let’s say your company has recently acquired another company that runs static routes on all its networks because not all their routers are Cisco routers and they are not ready for the complexity involved in running OSPF. Your task is to merge the newly acquired company’s networks with yours and ensure seamless communication across the networks while maintaining all routers.

The solution would be to implement route redistribution on the border router to redistribute all static routes into eigrp.

Network Topology

Image showing static and eigrp routes

Objective

From the network topology above, Router0 and s0/3/0 interface of Router1 are in eigrp autonomous system 25 while S0/3/1 of Router1 and Router2 are running static route. Our goal is to make sure that even though Router2 is not running eigrp, it should be able to reach Router0 and vice versa.

Implementation

Router0

Router0(config)#

Router0(config-if)#interface FastEthernet0/0

Router0(config-if)#ip address 192.168.1.1 255.255.255.0

Router0(config-if)#no shut

Router0(config-if)#interface Serial0/3/0

Router0(config-if)#ip address 192.168.4.1 255.255.255.252

Router0(config-if)#desc connection to Router1

Router0(config-if)#no shut

Router0(config-if)#exit

Router0(config)#router eigrp 25

Router0(config)#network 192.168.1.0

Router0(config)#network 192.168.4.0

Router0(config)#no auto-summary

Router1

Router1(config)#

Router1(config-if)#interface FastEthernet0/0

Router1(config-if)#ip address 192.168.2.1 255.255.255.0

Router1(config-if)#no shut

Router1(config-if)#interface Serial0/3/0

Router1(config-if)#ip address 192.168.4.2 255.255.255.252

Router1(config-if)#clock rate 64000

Router1(config-if)#desc connection to Router0

Router1(config-if)#no shut

Router1(config-if)#interface Serial0/3/1

Router1(config-if)#ip address 192.168.5.1 255.255.255.252

Router1(config-if)#clock rate 64000

Router1(config-if)#desc connection to Router2

Router1(config-if)#no shut

Router1(config-if)#exit

Router1(config)#router eigrp 25

Router1(config)#network 192.168.2.0

Router1(config)#network 192.168.4.0

Router1(config)#network 192.168.4.0

Router1(config)#no auto-summary

I will be back on Router1 to enter the command for redistribution after Router2 has been configured.

Router2

Router2(config)#

Router2(config-if)#interface FastEthernet0/0

Router2(config-if)#ip address 192.168.3.1 255.255.255.0

Router2(config-if)#no shut

Router2(config-if)#interface Serial0/3/0

Router2(config-if)#ip address 192.168.5.2 255.255.255.252

Router2(config-if)#desc connection to Router1

Router2(config-if)#exit

Router2(config)#ip route 192.168.1.0 255.255.255.0 192.168.5.1

Router2(config)#ip route 192.168.2.0 255.255.255.0 192.168.5.1

Router2(config)#ip route 192.168.4.0 255.255.255.0 192.168.5.1

At this point, we are almost done. The only problem is that Router0 has no knowledge of network 192.168.3.0/24. To achieve full connectivity, I will configure a static route on Router1 to reach network 192.168.3.0/24 and then redistribute this static route into eigrp autonomous system 25 so that Router0 can then learn about it via eigrp. See command below.

Router1(config)#router eigrp 25

Router1(config-router)#redistribute static

You may also like: How to redistribute between eigrp and ospf

Verification

Now let’s look at the routing table of Router0 with the show ip route command. See image below.

Image showing external route redistributed into eigrp

That’s it guys. To get the Packet Tracer file for this LAB, kindly drop your email address in the comment box.

Spread the love
Timigate

View Comments

Recent Posts

Optimize your Metro ethernet with Jumbo MTU

Optimizing Metro Ethernet segments with jumbo MTU (Maximum Transmission Unit) can significantly enhance network performance…

5 months ago

Mikrotik switchOS configuration: a step-by-step guide

MikroTik's SwitchOS is an operating system specifically designed for their line of network switches. It…

6 months ago

Improve your network uptime with VRRP right now

A properly configured VRRP setup does not only track device uptime but also tracks connection…

6 months ago

Have you been configuring NAT the right way on Mikrotik?

Network Address Translation (NAT) is a technique used in networking to map private IP addresses…

6 months ago

Implementing VXLAN over MPLS with Mikrotik

In the ever-evolving landscape of networking technologies, the demand for efficient and scalable solutions has…

7 months ago

Multi-Area OSPF implementation on Mikrotik routers

Setting up Multi-Area OSPF (Open Shortest Path First) on Mikrotik routers involves a few steps.…

7 months ago